Help required for Cesium

Hi team!
I hope you are doing well. I am facing a problem using Cesium in unreal engine 5.2. when I am rendering the scene in unreal, it does not render the cesium. Can you please help me with that I attached the render file as well.

Thank you
Zeeshan Hameed

The most common cause of this is that you’ve used a remote desktop solution of some sort (even if you’re not currently using one) and Unreal has disabled real-time mode. See here:

If that’s not it, please tell us more about how you got here. Was it previously working, and then it stopped? Does it work in the Cesium for Unreal Samples project? What tileset are you trying to use? Are there any errors in the Output Log?

Thank you, Kevin.

I am not using a remote desktop. I just simply install the plugin and add latitude and longitude, it works fine in Unreal but when I add it to the render queue it’s gone.

1 Like

Please help me with this.

Cesium uses the camera associated with the first player controller to drive tile selection. So if you render is not using the player controller’s camera, but instead using some other camera, you’ll see incorrect or missing tiles.

I am using a cine camera actor. Can you please help me? I think when I add render, tiles are loading or something. because when I add a third-person player it takes time to load in the start.

Is there any option where I can freeze the whole scene? so it does not load when I start rendering?

See it looks fine in preview mode, please help me with that I have to deliver this project and now I am stuck.

I tried to reproduce the problem you’re seeing so that I can give you more specific instructions, but I wasn’t able to. I created a new Level Sequence, and then on the Sequencer panel I used the “Create a new camera” button to create a Cine Camera Actor. Then I move that camera to a new area of the map and used the “Render this movie to a video” button on the Sequencer panel to record the video. Unreal automatically created a player controller and set its camera settings to reflect the Cine Camera Actor, so the video recorded perfectly.

So something must be different in your setup, and you’re not the first person to have this problem. But I don’t know what it is. Can you try following my steps above (creating a brand new sequence) and see if that much works for you, at least? Do you have any ideas about what might be different in your setup?

Thank you.
Sure I will try, and make a new project. Right now in this project, I am using some KITBASH assists and for lighting, I am using Ultra dynamic sky.


Hi, Kevin
I hope you are doing well. I created a new project the same thing happened with this one.

Ok, but did you try the Cesium for Unreal Samples project? And did you try following the procedure I listed above in order to record a video, and does it work for you? I don’t know what a KITBASH assist is, but did you try not using it and see if that made any difference?