Release 1.19 and KML stylemap still not working

I noticed via monitoring GitHub that release 1.19 was supposed to fix issues with KML Stylemaps.

It’s out now, and I’ve tried it out, and the stylemaps don’t appear to be applied still.

Here’s a sample KML file that I am rendering via Cesium 1.19:

Here’s the page where the file is rendered:

The little white segments here should be coloured.

In Cesium:

In Google Earth:

What am I doing wrong? Or is there still a bug?


Thanks for bug report. I’ve fixed the issue in

The issue was that the KML document was using styleUrls incorrectly. A styleUrl that references a Style within the same document should start with a #. This is a common enough issue among KML documents out in the wild that it’s handled by Google Earth.

We actually handled it if the styleUrl was in a Placemark, but weren’t handling it within a StyleMap. This fix will be in 1.20 or you can pull master down once the PR is merged.

Cool. So I was doing the wrong thing AND there was still a bug.

Awesome response on this one. I look forward to trying out the fix.


I have an issue related to this segment of the KMLDataSource. Tom, do you have time to take a peek at it? I still need my hack even with your latest fix.!topic/cesium-dev/sdvlAuUfxgA

Thanks for letting me know. Sorry I took a little while to get back to you.

You’ll be happy to know that the issue should be fixed once is merged.