removeDuplicates error where i didn't get it before: Chrome v. IE makes a difference.

I just updated to 1.25 from something like 1.20 or so and getting the new and unexpected error below. Appears to be polygon related and occurs in both czml and kml data sets.

After a day of chasing it I figured i’d try an experiment and it blew my mind - I consistently get the error in chrome but not IE…

Chrome: Version 53.0.2785.116 m (64-bit) - consistently fails every time - even with just one 3 point polygon

Edge: Microsoft Edge 38.14393.0.0 - consistently no error

FireFox: consistently no error

IE: 11.183.14393 - consistently no error

Anyone encounter this?

TypeError: h.removeDuplicates is not a function
TypeError: h.removeDuplicates is not a function
at (http://localhost/apps/cesium/Build/Cesium/Workers/createPolygonGeometry.js:230:18724)
at Object.m.polygonsFromHierarchy (http://localhost/apps/cesium/Build/Cesium/Workers/createPolygonGeometry.js:230:23397)
at Function.I.createGeometry (http://localhost/apps/cesium/Build/Cesium/Workers/createPolygonGeometry.js:231:540)
at r (http://localhost/apps/cesium/Build/Cesium/Workers/createPolygonGeometry.js:231:2019)
at i (http://localhost/apps/cesium/Build/Cesium/Workers/createGeometry.js:77:25235)
at http://localhost/apps/cesium/Build/Cesium/Workers/createGeometry.js:77:24444

Additional data on this:

It appears that the issue even in chrome can be eliminated if I remove a few placemarks that are LineStrings. Remove these and it works in chrome too. I tried all kinds of combinations to determine if it was a specific aspect of the line strings - it’s not.

Just continuing FYI


When switching between version of Cesium, the first thing to try is clearing our cache/cookies. Sometimes that has weird side effects depending on what has changed.

If that doesn’t fix your problem, could you please send over a KML file to reproduce the issue? I haven’t seen this happen before.



I cleared the cache and the error went away.

I often clear my cache when developing code but usually find that whereas 2 years ago there was always stuff floating in the background somewhere I generally don’t have those types issues any more. Is there s known set of things that are left in the cache?

Glad to hear that worked for you. I’m not sure exactly what things are left in the cache, I just know that clearing it usually clears up weird problems like that.