Error occurred when upgrading Cesium 1.26 to 1.29

I got this error after upgrading the cesium js version 1.26 to 1.29

  1. In first image the the Bing map not loading in proper way.

  2. Second image after adding the entity.


Have you tried clearing your cookies/cache? Sometimes that can lead to odd side effects when switching between version of Cesium.




Yeah, i cleared all my history from browser. After than also we getting this error.

PFA. its contains the screenshots of error pages

Hmm, I haven’t seen that problem before. Are you able to run Sandcastle on our website?
If so, could you create short code example that reproduces the problem there?




I'm seeing the exact same error as shown in Sanjeev's 'BUG1.jpg' after upgrading. I was able to determine that it was because `cesium/workers/combineGeometry.js` was cached in the browser.

We're using a cache-buster when including Cesium.js itself in our application, e.g. src="cesium.js?v1.29" so that whenever we upgrade we can ensure our clients receive the latest version. As far as I can tell, there's no way to do the same for the JavaScript files that Cesium loads internally.

Have I missed a configuration option that can be set to ensure the latest versions of the internally-loaded files are retrieved? Or, are you aware of any other way we can force the latest versions to be downloaded?



Hi Seth,

Sorry, I don’t have any good suggestions here. Does someone else have any ideas?

This is one of the more common problems reported here on the forum, so it’d be great to have a solution. I’m not sure an easy one is out there though.


Hi Hannah!

Thanks for your quick reply.

What we’ve decided to do is deploy cesium in a folder that contains the cesium version number, such as “/cesium_1_29/…”. We’ll change the folder name and CESIUM_BASE_URL each time we upgrade, which should take care of our caching issues.

Thanks again!