Server maintenance issue?

The last two mornings, around 8:00 CST. I seem to be getting server errors like

Failed to load resource: the server responded with a status of 404 (Not Found)

require.js:138 Uncaught Error: Script error for: Shaders/DepthPlaneFS

Yesterday, the error went away after a bit.

Is there some maintenance time when I should suspend work? Is the problem on my side?


I’m not aware of any problem. Are you still seeing this?




No I haven’t. It only happened those two days. I got up and worked for a while and then around 8:00AM the error would appear. I would turn to other work on our server, from home and all was well.I use a VPN connection. After a bit, I went back to Cesium and, having done nothing since I stopped everything was good here as well. I posted the error since it seem to be referring to remote resources. Probably it was somewhere in the chain of local connections.Sorry to have bothered you with this.



Is there a reason that Cesium just stopped loading, after working for nearly a year on my site. Nothing changed but the cesium server won't load terrain.

I'm seeing problems with previously working code as well.

Are you seeing the issues I mentioned, i.e.: just loading a black sky with stars, but no terrain?

I've never seen this happen before... just as if the server doesn't like us anymore.

It's been working famously for many months... afraid to change anything on this end, unless I can confirm it's not a cesium server issue.


The URL changed months ago, and they just dropped the redirection. The new URL is on this page:


You most likely need to update your terrain url to


For example, see

The old url was deprecated with the Cesium 1.11 release. See


Thank you Patrick

I did change this from the // to //

but it still doesn't load. Still a black space with stars.

Here's the site...

I just checked out the site and your app is still requesting tiles from

Replace with and you’ll be good to go.



Thank you all for your help. Very, very much appreciated.

It works now.


Jon - I’m so glad it worked for you. Awesome app, by the way!