TileMapServiceRasterOverlay not working in UE4 while URL Works in CesiumJS

Hello All,

Thank you for your attention, Can someone help me with this please?

I was able to setup Geoserver and host a TMS Raster Overlays, this works in Cesium JS with the following piece of code: (tested in sandcastle)

var viewer = new Cesium.Viewer("cesiumContainer", {
  imageryProvider: new Cesium.TileMapServiceImageryProvider({
   url: 'http://localhost:8080/geoserver/gwc/service/tms/1.0.0/my_Workspace_1:ff2_raster@EPSG:4326@png',
   fileExtension: 'png',
   maximumLevel: 15,
   minimumLevel: 0,

  baseLayerPicker: false,
  geocoder: true,

However, when i use the same url in UE4 + Cesium in the CesiumTileMapServiceRasterOverlay, i do not see the overlay? I only see the Bing Imagery or nothing when I am offline.
Can you please suggest what i might be doing wrong?

Ive also resolved CORS issues that come with geoserver, so thats not it as it clearly works woth JS.

Thank you very much!

Kind Regards

This issue requires further investigation. Some additional context:

  • Setting the Material Layer Key does not fix the problem
  • Loading the file in CesiumJS results in errors along the lines of An error occurred in "TileMapServiceImageryProvider": Failed to obtain image tile X: 1 Y: 1 Level: 1.

Hi @vamsh.chittaluri,

On your imagery URL, please try appending /tilemapresource.xml to the end of the URL.

If that isn’t working, I’d suggest trying to host and load this Natural Earth II imagery, just to check if you are able to load that. You’ll also want to append /tilemapresource.xml at the end of the localhost URL.


Do u solve it ,I think the url need some XYZ?

Hi, have you solved this problem? How did you do it, can you share?

I think the problem in this thread is the same as here:

I was able to get through this using maptiler…their export offers the particular config that is accepted by unreal’s cesium implementation. the tiling scheme is OSGEO TMS (Bottom-left Origin).