Transparent Moon Problem

Cesium demo depicts a Lunar mission with trajectories that were generated from NASA’s General Mission Analysis Tool (GMAT),
Moon’s orbit and a lunar probe trajectory are loaded from CZML files. Presently, the CZML file loads a solid ellipse as depicted in the first image. It appears that there is a Moon peeking out from behind the ellipse.
Notice that the from this view point the ellipse hides the Earth. If I change the show parameter to false in the CZML file, the Moon is still there but it is transparent. I the image, it appears that the Earth is in front of the Moon but from this view point the Moon is in front of the Earth.
How do I get a solid Moon?

Here a snippet of the CZML:

[ {
“id”: “theMoon”,
“ellipsoid” : {
“radii” : { “cartesian” : [ 1737000, 1737000, 1737000 ] },
“fill” : true,
“solidColor”:{ “color”:{ “rgba”:[ 100,100,100,255 ] } }
“show” : false
“billboard” : {
“eyeOffset” : {
“cartesian” : [0.0, 0.0, 0.0]
“horizontalOrigin” : “CENTER”,

    "pixelOffset" : {
        "cartesian2" : [0.0, 0.0]
    "scale" : 0.8,
    "show" : true,
    "verticalOrigin" : "BOTTOM"
"label" : {
    "fillColor" : {
        "rgba" : [255, 255, 0, 255]
    "font" : "bold 10pt Segoe UI Semibold",
    "horizontalOrigin" : "LEFT",
    "outlineColor" : {
        "rgba" : [0, 0, 0, 255]
    "pixelOffset" : {
        "cartesian2" : [10.0, 0.0]
    "scale" : 1.0,
    "show" : true,
    "style" : "FILL",
    "text" : "Moon",
    "verticalOrigin" : "CENTER"

“path” : {
“color” : { “rgba” : [150, 150, 150, 255] },
“width” : 1.5
“position”: {
“referenceFrame”: “INERTIAL”,
“cartesian”: [ ]
} }]

We have depth testing disabled for the moon since most people using our library are making earth-centric apps. The problem should be fixed if you change this line of code to depthTestEnabled: true:

Alternatively, I posted a suggestion in your other forum post for how to use our moon texture on your moon ellipsoid and hide our moon if you wanted to do it that way instead.



Hi Hannah. I'm currently working on a simulation of Apollo 11, so the moon is important for obvious reasons. I tried your solution of setting depthTestEnabled to true for the moon, but with no result.

Another suggestion? I couldn't find the other post you were referring to. Thanks.

I think this was Hannah’s suggestion in the other thread:

Yeah. It appears he created an entirely new moon in CZML. But wouldn’t it be easier to just modify Cesium’s default moon, rather than create one from scratch? Shouldn’t changing depthTestEnabled to “true” solve this issue for me? That’s what I’m confused about.

I wonder if something else has changed since. Would you be able to open a new thread with a demo and/or screenshots of the issue? The original screenshots from this thread aren’t working anymore.