UI problem with the Cesium window : add buttons (+) do not work anymore

Hello, I am just new to Cesium. I have followed the quick tutorial and everything was fine. But now I started a second scene and when I try to add new Cesium World Terrain using the Cesium window (Quick add Cesium ion Assets) the plus button (+) do nothing except for blank 3D tiles. I can use the Cesium ion assets window to add a Cesium World Terrain and then add for instance bing maps Aerial but I cannot add a dynamic camera for instance as this feature is not listed in Cesium Ion Assets window.
I have no clue why the (+) buttons do not work anymore (tried to restart Unity but does not help).

Any ideas ?

Hi @Aurelien_LHERBIER,

This sounds like a bug, the UI shouldn’t just stop working like that. But if you have an item already in the scene (e.g. Cesium World Terrain or a Dynamic Camera) and you try to add it again from the Quick Add panel, it will just select the instance that already exists. So to clarify, you’re saying the add buttons don’t work when you have nothing in the scene?

Can you also tell me what operating system and Unity version you’re using? I will try to replicate this on my end.

I just cloned cesium-unity-samples, opened a new scene, and tested the add buttons in the Cesium panel. They all work for me on Windows with Unity 3.14f.2021. Is there something that you did differently @Aurelien_LHERBIER ?

Hi, I am using Unity 2021.3.13f1 on Windows with DX11
Here after are snapshots of the problem (step1: scene is fresh new : just camera + sun light + global volume (URP scene), step 2: try to add world terrain + bing aerial imagery (does not work), step3: try to add Blank 3D Tiles (it works and creates a Georeference with 3D tileset. I can also use the bottom panel Cesium Ion Assets to add manually assets but dynamic camera does not appear in this list for instance)

Again, It worked perfectly in the first place. But for some reasons it is now broken. And I have no error message in the console. I suspect that the source of the problem is a bad internet connexion because the blank 3D Tiles probably does not need internet and maybe that is the reason why this one works perfectly. I will try again in a place with better internet connexion to see if this is the reason.

Hi @Aurelien_LHERBIER,

A bad internet connection would make sense for the ion assets, but the Dynamic Camera doesn’t need internet to work. So if that button is broken as well, then we have a problem.

May I ask how you set up the project? Did you create an entirely new project, then import the Cesium for Unity package?

I have indeed created an entirely new project.
I have followed the quick start tutorial Cesium for Unity Quickstart – Cesium
I added the scope registry and then I obtained the Cesium for Unity package in package manager (version 0.2.0) and installed it.

Hi @Aurelien_LHERBIER,

I’m afraid I still can’t replicate the error, though it seems that you may not be the only one experiencing it. I wonder if there’s a difference in behaviour in versions of Unity 2021.3+ before 3.14. I’ll check out how it works on 2021.3.13f when I can.

Thanks for your reply. The behavior is still quite unstable (sometimes it works sometimes not, but the for dynamic camera I never managed to add it again from the quick add menu) but in the end I manage to get what I needed for tests, so I am fine. You can close the topic


1 Like

Hi @Ember6489,

Thanks for the report. I’m actually not able to replicate this issue. Using Unity 2021.3.14f, I can narrow the window, and as long as I can still see the button, clicking it will work. What version of Unity are you using?

Also, when the window is small, are you still able to hover over the buttons and see tooltips pop up? For example, I can see this when I hover over the add button:


Hi @janine ,
Thank you for your reply.My Unity version is 2021.3.19f1c1 and I have tried it with the version Unity 2021.3.14f1c1 and Unity 2021.3.10f1c2,but I still have the problem and I have the tooltips.
bandicam 2023-03-02 11-21-07-603 00_00_00-00_00_30

But I found an interesting thing,My PC monitor resolution is 3840*2160,As you can see if I set my scale of screen with 150% the “+” button not useful when the window is small.But if I change the scale of screen with 200% the issue will never occur.So I think it may be an Unity bug.
bandicam 2023-03-02 15-54-15-205 00_00_00-00_00_30
bandicam 2023-03-02 16-01-56-874 00_00_00-00_00_30
Hope it’s help.

1 Like

I can reproduce this on my 4k monitor with 1.5 scaling. Strangely, 1.25 scaling seems fine, too. It does seem like a Unity bug.

你好 我也遇到了相似的问题 我尝试界面给他拉宽一点 然后就得到了解决 关于编辑器 我把unity3.x的所有版本全部下载使用看了一遍 但是该问题还是没有得到解决 ,所有我认识是不是可能是一个bug