Unable to load globe using ANGULAR-CESIUM

I’m not able to load globe while using angular cesium in my project.
I have created a component as shown below

<ac-map style="height: 500px; display: inline-block; width: 100%;" >

I’m expecting a simple globe to come up but I only get as shown below.

Can you help me.
I’m using version as specified below.
Angular CLI version: 8
Angular-Cesium version: 0.0.73

Hello @Ankita_Gupta :wave:

Have you tried to set the default access token for Cesium Ion like this?

Hey @Aristeidis_Bampakos
Does it require default access token because its not mentioned in angular-cesium documentation?

As far as I know, the default access token is part of the Cesium ION platform not specifically to the angular-cesium library. I had seen this error before in an Angular application that uses Cesium without angular-cesium and when they set the default access token, it worked :wink:

Cool! Thank you very much for the response @Aristeidis_Bampakos
I will give this a try

Have a great rest of the day!

In a documentaion it is mentioned ‘Access tokens provide authentication when using Cesium ion’s REST API and are used to link API requests to your account.’
We are not using any cesium ion rest APIs, instead directly using angular-cesium library. So is there any other solution.

Not something that I am aware of @Ankita_Gupta :thinking: You should try asking them in their GitHub repository - AFAIK angular-cesium is not supported officially by Cesium, it is a 3rd party library.

Hi there,

Just to clarify– An app using the Cesium ion API when loading any default terrain or imagery on the globe. If you would like to avoid this, you can use another imagery or terrain provider.


1 Like

Thank you @Gabby_Getz