Unable to view tileset.

**Hi i tried converting a gml file to 3dtiles. But i’m unable to view the tileset. I’m getting a warning **

Cesium.js:472 This tileset JSON uses the “content.url” property which has been deprecated. Use “content.uri” instead.

Cesium.js:472 Required property geometricError is undefined for this tile. Using parent’s geometric error instead.

what could be the reason.

I have attached the tileset.

Building.zip (1.43 MB)

Do you have geometric errors defined for each tile?

No i don’t have any geometric errors defined.What happens if there is no geometric errors defined ?

Defining a geometric error is required. It’s how the client knowing when to render a particular tile or refine to its children. Without it, no tiles will be shown.

Have you tried uploading your building data to Cesium ion (https://cesium.com/ion) to get a 3D Tileset that way?

Thanks.I tried uploading to cesium ion.It worked. But why I’m unable to see the tileset which i have converted.This time i have defined geometric error also for the tiles.But still the same issue.Attached the tileset .

misretiles3.zip (1.45 MB)

What did you use to create this 3D Tileset?

There doesn’t yet exist a full 3D Tiles validator, but you can try adding the Cesium 3D Tiles inspector to your scene:



This will help show some debug properties that might make it easier to find where the issue is. Here’s a Sandcastle example showing how the inspector works:


I would start by visualizing the bounding boxes which you can enable under the “Display” tab.

Thanks for the example omar.

I tried with example,I’m able to view the tileset but not able to understand why its falling in wrong place.I created the tileset using FME. Does cesium ion uses fme for conversion? Why the tileset is not projecting properly?I even checked the projections and transformed the projections accordingly. I’m using cesium version 1.61.Attached the source gml file.

Missouri-29029-001.zip (722 KB)