3D Tileset not showing in Cesium Ion

Dear Cesium Community,

I have created a 3D object that used as a geometry instance and placed at a set of point coordinates. I used lod2implicit geometries.

My input was a citygml exported from an original sketchup model and a shapefile file for the points. I created a final citygml file combining those two with the instanced geometries. When I upload it to cesium ion as the citygml it works perfectly fine and cesium creates the tiles for me.

Since I do need this data as a tileset format to use in another application, I then tried to transform this citygml into a 3D Tile with FME. I simply used the 3D Tile writer. It works without errors and I also can upload it in Cesium ion and I don’t get an error. However, when I try to use this 3D Tile in my Stories or see it in my assets on Cesium Ion, I cannot see anything. My 3D objects do not show up. They are not floating or underneath the terrain, they simply are not there at all.

Does anyone have an idea what the problem might be? Am I missing anything in the conversion process that hinders me from being able to visualize this tileset in Cesium Ion? The citygml that I created seems to be perfectly fine and usable in cesium but the 3D Tileset that I create with FME does not show anything in Cesium.

The coordinate system of my citygml that I uploaded to cesium is EPSG 25832. I already tried reprojecting it to WGS 84/ EPSG 4326 but that does not solve the problem either unfortunately.

I would really appreciate some help on this. Thank you!

Hi - Are you able to share the asset ID for this data?

Can you clarify which of these workflows you are using and which ones are working? I wasn’t able to get clarity from your post about which one worked and which didn’t.

  • CityGML → FME → 3D Tiles output → CesiumJS
  • CityGML → FME → 3D Tiles output → Cesium ion → CesiumJS
  • FME → CityGML → Cesium ion → 3D Tiles output → CesiumJS
  • Something else?

Thannk you very much for your response.

We have actually figured it out now. I just forgot to include the data folder in a zip file with the tileset.json. That did the trick.

Makes sense too because I did not get any error messages along the way.

Have a great day

Sounds good. Thanks for the update. Let me know if we can help with anything else.