weird zoom behaviour


I am experiencing a weird behaviour when zooming. hopefully this video illustrates what I mean:

1. (first 10 seconds): if – after a page reload – I don't move the mouse cursor, cesium seems to think that the mouse is in the upper left corner of the viewport.

2. (rest of video): zooming seems to get stuck in a way, or does not react to user input. — at first I thought maybe 'inertia scrolling' on the mac has to do with it. but weirdly enough, it does not seem to happen when I remove the white gltf model entity (white rectangle)! see this video:

Thanks! I’ve answered your question in your GitHub post. In the future, please post on the forum first.


Thanks! I've answered your question in your GitHub post. In the future, please post on the forum first.

ok, will do.

I wasn't sure though if both were in fact connected, so I treated them as two different things ...


sorry, it's not entirely clear to me how the 'zoom limit bug' is related to what I'm describing in

as a matter of fact, it also happens without setting zoom limits:

// limit zoom range:
// scene.screenSpaceCameraController.minimumZoomDistance = minZoom;
// scene.screenSpaceCameraController.maximumZoomDistance = maxZoom;

// disable certain interactions:
scene.screenSpaceCameraController.enableTilt = false;
scene.screenSpaceCameraController.enableLook = false;

// looking straight down at the earth with the heading oriented to north:
    // setting this does not seem to make a difference
    heading: 0.0,
    pitch: -HALF_PI,
    roll: 0.0,

if you zoom all the way out, pan around wildly, and then zoom back in, you should be able to reproduce it:

I am experiencing exactly the same bug. For me it used to happen in both firefox and chrome (Windows 10 64 bit) , then it suddenly fixed for chrome (don’t know how), but it’s still happening in firefox. It happens even without limiting zoom, on any cesium project. Zooming becomes slow and choppy (unresponsive to mouse) when close to the ground, and it seems that the software miscalculates the zoom point. It works fine when I switch to fullscreen though. My video card is xfx radeon r9 270x (could it be video card related?).

Hi there,

It’s possible that this is a bug – it may also be related to this issue:

Can you post a screen capture?


  • Rachel