3D Is not working

1. A concise explanation of the problem you’re experiencing.

From the demo website (https://cesiumjs.org/) I can see 3D visualization of mountains.

When I run the code locally, or on my server, 3D visualization is not present anymore.

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

I didn’t modify the code from the official release.

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I need 3D visualization of mountains.

4. The Cesium version you’re using, your operating system and browser.

CesiumJS 1.60, Windows 7, Firefox 68.0.1

Are there any messages in the developer console (F12)?

Does the Cesium Viewer app work?

Cesium World Terrain is not enabled by default. You can turn it on by clicking on the base layer widget (top right, next to the question mark button) and select “Cesium World Terrain” at the bottom. You can also turn it on programmatically in your code, see adding Cesium World Terrain in the getting started:


Thank you, that was the problem.

Now the mountains are on top of my KML points (which are now invisible, I can see them by going under the mountains).

I tried changing the Z coordinate but nothing really changes.

Any ideas? Thanks.

There is a clampToGround option you can set to true when you’re loading in a KmlDataSource:


Thank you so much.