3d-tiles validation

1. A concise explanation of the problem you’re experiencing.

I would like to validate a 3d-tile sample with https://github.com/AnalyticalGraphicsInc/3d-tiles-tools/tree/master/validator

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

**when I run the command **node ./bin/3d-tiles-validator.js ./specs/data/Tileset/ nothing happend, no output, …

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

Do I miss someting ?

4. The Cesium version you’re using, your operating system and browser.

**newest - but I think the validator uses 1.39 resp. 1.55 **

I think it is not a problem of the validator - can you explain how to use the tool or is there another tool where I can validate a 3dtiles dataset ?

We don’t currently maintain a 3D Tiles validator, although we’d like to have one eventually. That branch is an experimental tool that was never officially released.

How are you creating your 3D Tiles? Is it exported from another software or are you building your own 3D Tiles generator? Are you having any issues with it?

How Omar,

i generated the 3d-tile by my own and got an error from CesiumJs during read - but this doesn’t help very much.


Have you tried created your 3D Tiles with Cesium ion (https://cesium.com/ion/) ? You can upload your source data there and get a 3D Tileset.

Otherwise, have you tried using the 3D Tiles inspector? That provides some debug info that might help: https://sandcastle.cesium.com/index.html?src=3D%20Tiles%20Inspector.html

If you’re using the unminified version of CesiumJS it should make it easier to see where the error is coming from.