3D Tileset not showing

I use this template from github to make a sample project
I just added a new Blank 3D tiles tileset and added the following url to
On the editor screen, I can see the model, but when I build the application and put it into Meta quest 2, my model is not visible.(I moved the camera to make sure the camera could see the model)
I am using Unreal engine 5.1.1 Cesium latest version 2.2.0.
Can someone give me a suggestion?

Image on editor:
Image on meta quest 2:

Which model isn’t visible in the Quest 2 screenshot? I can’t quite tell what I’m looking at.

Sorry for not making it clear. it is a bridge.

Ok, but I see the bridge in both of your screenshots, even though you said the model (the bridge?) is not visible on the Quest 2.

The 2 models are overlapped, I moved the bridge a little to the right so you can see it clearly, I can share the file with you so you can see it more clearly

This is my project, I’ve been stuck with this bug for 5 days and I haven’t been able to find the problem. Any ideas or suggestions from you would be greatly appreciated.

Does it show up in Play-in-Editor? Does it show up in a built application for other platforms?

I haven’t tried running it on other platforms, but in the editor I can still see the model. When I tried debugging, I saw an error as shown below

Hmm that’s pretty interesting. Do you know what exactly triggers those “bad any cast” errors? You haven’t purposely turned off C++ RTTI by any chance, have you?

These are the steps I follow:

  1. Download sample project: Release Cesium for Unreal VR Tutorial v1.2 · CesiumGS/cesium-unreal-vr-tutorial · GitHub
  2. edit settings according to this example: Build for Quest – Cesium.
  3. Add blank 3D tiles tileset with url
  4. install on quest 2

I’m not sure what C++ RTTI is, but I don’t think I’ve seen it before

Can you please try a built application on Windows and see if it has the same problem? I don’t have access to a Quest 2, so I can’t try your procedure directly. I’m trying to find someone who does to help you, but in the meantime it’s worth trying some more debugging steps.

Scanning through the “Build for Quest” instructions you linked, one thing that jumps out at me is that you might try disabling that “Experimental Occlusion Culling Feature”. It’s experimental for a reason.

  • I tried building on the desktop environment and the program ran perfectly. The bridge model is still visible. (I’ve moved the bridge to the right so you can see it clearly)
  • I tried turning off the “Experimental Occlusion Culling Feature” but on quest 2 the bridge model still cannot be displayed.

Ok, thanks for checking. Hopefully one of our VR developers will be able to jump in soon and take a look.

1 Like

Hi @Lam_Vu_The

Are you using translucent materials for both the bridge and Cesium Terrain tileset? I’m curious if when testing on the Quest if you can see the other bridge from a lower angle looking upwards where the world terrain tileset wouldn’t occlude it. This could rule out it being a draw order issue.

My apologies as I’ll be tied up for the next two days, but I will look into this asap.

1 Like
  • I tried to disable the background model, leaving only the bridge visible. When build on the Quest 2, the bridge is still not visible. In previous tests, I tried to view the model from different angles. This suggests that the issue is not with the draw order.
  • I am not using translucent materials for the bridge. The bridge is in the .IFC format.