A phenomenon where the line trace goes through without hitting the 3D tileset

The static mesh is registering a hit, as shown in the picture, but it’s not being applied to the 3D tileset.

I unchecked the Frustum Culling based on the Cesium topic.

I created this actor using a blueprint class and this is the corresponding node.

I need help. thank you

Can you confirm that the “Create Physics Meshes” option is checked on your tileset?


Yes, that option has been selected

The UE engine version is 5.1.1, and the Cesium plugin version is 1.23.

Your Blueprint looks a little bit surprising. You’re starting the line trace at a cube (makes sense), but then ending the trace at (Cube X, Cube Y, Cube Z * 10). So that isn’t going to work at all if the cube’s Z coordinate is positive, because the trace would go up instead of down. Are you sure the (negative) Z times down is far enough to reach the surface? The fact that we can’t see the shadow of the cube on the terrain in your screenshot indicates that it might be farther above the surface than it appears.