Holes when rendering with path tracing

Hi all

I’m relatively new to Unreal, but the combination of Unreal and Cesium is great and I’ve spent a lot of time with it lately. I have one big annoying issue that I hope you can help with.

We are doing an architectural animation with Cesium (google photorealistic tiles) for context, set up with animated camera and light movement in the Level Sequencer and rendered out through Movie Render Queue.

When we render with Lumen (deferred) all cesium tiles renders well.

We do prefer to render with path tracing though for better shadows and reflections, but when we do that we get the issue. The first typical 200-300 frames render well without issues, but then holes in the tiles appear. Often the camera turns and newly visible tiles don’t load but sometimes it’s also tiles that have been in the frame all along which suddenly disappear. Both cases are shown in the screenshot below.

Do you guys have any idea what’s causing it and how we can fix it?

One easy but dumb fix is to render lots of sequences at 100 frames each and put them together in post, but it would be nice if there was a better fix that didn’t need a hack.

Also, another minor annoyance is when small areas suddenly change a little. Like a tile with for instance some trees that suddenly get a little more or less definition that gives this tiny glitch or flicker in a tile somewhere in the screen. Is it possible to prevent this somehow?

Hi @vismodk,

This is just a hunch, but does changing the “Maximum Cached Bytes” on the tileset make a difference? It may prevent those tiles from unloading and reappearing as blank.

I’m afraid it’s not possible to prevent tiles from changing. By nature, 3D Tiles are loaded / unloaded as necessary for the current view of the camera. I can only recommendations to reduce the behavior:

  • Decreasing the “Maximum Screen Space Error” can encourage higher detail tiles to stay on screen longer, though at the cost of loading more tiles overall.
  • Disabling the “Enable Frustum Culling” option should prevent tiles from being culled by the camera turning.

If you need to prevent tiles from changing, and the camera isn’t moving, enabling “Suspend Update” might be helpful too.