Alpha texture problem ,gltf and 3DTiles

I’m faced with a problem of rendering gltf alpha texture.
I tried to render “AlphaBlendModeTest.gltf” , from KhronosGroup sample.
I got different results between rendering as entity gltf model and as 3DTiles converted from gltf.
Which is a right result ? I thought opaque_mode and cutoff_mode of 3DTiles rendering are not right.

gltf is converting to 3DTiles with Cesium Ion.
Cesium version is 1.95.

Thank you.

1 Like

Additional infornatiin…

Converting flow is as bellow.
Is there anyone who knows about this problem?

This is not yet a solution, but just a comment for now: The resulting asset in the 3D Tiles case seems to use the same material for the different elements. This might be caused by the fact that the materials are nearly equal: They only differ in the opacity and alpha cutoff values. But this looks like a clear bug. It is already tracked internally, but the reason for why this happens this still has to be investigated.

@cccCesium If you have some additional bandwidth to help troubleshoot, please let us know. We’d be happy to advise and to review a potential fix. Thanks!

Thank you for replying.

I tried another method.
When I composite copied 5 layers ,original MASK mode is inherited in 3DTiles.
Strangely enough, some of textures are not fit this pattern. They can inherit their alpha mode to 3DTiles without compositing layers. I don’t know what is the difference between them, though it seems to be associated with contrast.

Thnak you.