Blank Screen with CesiumJS


I am trying to follow this tutorial provided: Build a Flight Tracker – Cesium
but when I start step 2, and I try and do something like

const viewer = new Cesium.Viewer('cesiumContainer', {
      terrain: Cesium.Terrain.fromWorldTerrain(),

the screen goes blank. This also happens if I try to load in OSM buildings. This happens to me in the Glitch webpage but also on my local machine too. How can I fix this?

Hi, do you see any errors in the console or network request failures? What version of CesiumJS are you using?

Hello, I do not see any errors, it just says listening on port ****, as if its working. I have attached screenshots using the webpage provided in this tutorial. Build a Flight Tracker – Cesium. It shows that when I add in the buildings, everything goes white. I even tried running “refresh” in the terminal with no success.

I managed to fix it by making the <script> tag into <script type="module">.

I then had an issue on my local machine, where everything would be displayed but no terrain would appear, when I was using CDNs. I fixed it by running the project using NodeJS and Express like the Glitch site does, and everything seems to be working.