Cartographic Polygon Refresh & Movie Render Queue

Every time I open my UE Project, I have to “refresh” my Cesium Cartographic Polygon via the Cesium Polygon Raster Overlays by going to the…

1- select Cesium3DTileset -->> 2- select the Cesium Polygon Raster Overlays -->> check and then uncheck the options I’m using (like Invert Selection or Exclude Selected Tiles) to get the masking to activate

This process also needs to happen anytime after a recompile or other action that seems to somewhat reset the scene, say something like going into Game Mode or Play Editor for rendering.

I’m attempting to render out a Level Sequence using Movie Render Queue or the standard Level Sequencer render button for that matter, and when I do, just as when I first open my project at UE startup, I have to “refresh” the Cartographic Polygon masks via going to the Raster Overlays, but I have no idea how to do this… do I need a Blueprint on Event Begin Play or something? If so, how would it need to be setup? Any suggestions are greatly appreciated!

Thanks in advance,

I’m not quite sure why you would need to manually refresh on load like that. But you didn’t say what problem you’re solving by doing that. What doesn’t work if you don’t refresh?

Hi Kevin,

Ah yes, I see how not having that info might be an issue! :upside_down_face: So the reason for it, is because the “cropped out” areas that I’ve generated with the Cartographic Polygons are not enabled it seems when I start the project, or consequently, when launching renders. So essentially I have to go to the Raster Overlays I’m using to “manually refresh” the mask by checking and unchecking one of the options as seen in the image in the original post and the video I’m about to send ya.

I’m going to send you a DM with a video describing the issue visually to assist. Thanks for your help with this!


I haven’t looked at your project yet, but at least the clipping in the Cesium for Unreal Samples project works immediately on load, without the need to immediately refresh anything. If it’s not working in your project, I think the first thing I’d check is that “Auto Activate” is enabled on the clipping raster overlay. It should be on by default, but maybe it got toggled off somehow. Without that, the overlay won’t automatically attach to the tileset.

Auto Activate is on for both Raster Overlays. I wonder if it could have something to do with the fact that the ones that are not working are inside of the one that is? The “Remove” of the roof, parking lot, entry, and exit are inside of the footprint of the “Remove Inverted” of the main world space I’m masking out.

“Cesium_Crop_RemoveInverted” (area outside of focal point) seems to be working the

“Cesium_Crop_Remove” (roof and parking lot) is not

Oh hang on, you have multiple clipping overlays? Have you assigned each a unique Material Layer Key and created a custom material that supports more than one clipping layer?

I wrote some very brief instructions for how that can be done here:

1 Like

Hi Kevin,

I’ve looked through the documentation and can’t seem to find how to locate the MI_CesiumThreeOverlaysAndClipping material instance, the material slot for the Tileset is blank. I noticed in other threads, that it appears that they are accessing the material items in the Layer Parameters as part of a Material Layered if I’m not mistaken. I’m not able to find the material or material layered/function, I can’t figure out how to get to Layer Parameters as a result to duplicate the material instance.

Can you help me find this please?

You can find it in the Content Browser, but only if “Show Engine Content” is enabled (because when you install it via the Epic Launcher, it ends up as an engine plugin).

1 Like

Ah, very nice, thanks for the heads up on that, can’t wait to see if I can finish it up now! Thanks Kevin, I’m gonna go give that a try!

Sweet, that worked brother, thank you!! Not gonna lie, it’s a little confusing at first to follow, but once I untangled the mess in my brain, it worked out great! Now on to the freezes in Movie Render Queue, ugh! :wink:


The MRQ freezes should be fixed in v1.30.1, so try upgrading if you haven’t already. If you’re still seeing freezes in that version, let me know.

Ironically I upgraded it this morning, and sure enough, it rendered after I applied the clipping overlay fix, I thought maybe they were related! Thanks for all your help Kevin, great job on the plugin to you and the team, cheers!!

  • LOCIHarp