Cesium Cartographic Polygon not clipping

I am using UnrealEditor 5.3.2 with Cesium for Unreal v2.0.0. I’ve followed the instructions on: Cesium for Unreal Quickstart – Cesium for setup. I am now following the instructions on: Clipping Tilesets – Cesium, and have made it to Step 2, but the tileset isn’t automatically updating to hide the parts of the tileset mesh within the boundaries of the polygon I created. I did search the forum for others having this issue before posting this, and didn’t see anyone else having this problem. If anyone is interested in helping, I would be happy to provide screenshots, or even stream video on Discord to go through the steps. This is an amazing plug-in, and I just want to be able to take full advantage of its features. Thank you in advance for anyone taking the time to read this post!

Additionally, I am just curious on the best method to specify map coordinates to the polygon points? I can get relatively close, and I realized (too late) that not having the settings to “absolute location” was causing them to drift as I moved around the map. Live and learn!

Have you tried clicking “Refresh Tileset” for the tileset you are working with?

Hello Brian, yes I did try the refresh Tileset button from the path Outliner>CesiumGeoreference0>Cesium3DTileset>Details>Cesium3DTileset (Instance)>Cesium>Refresh Tileset. I believe that is the button you’re referring to. I am wondering if I need my own API key to use Google Photorealistic 3D Tiles, or if I can continue using the Cesium ion asset for this project? I’ve also saved the file, exited UnrealEditor and logged restarted the application in case that was causing some sort of hang-up. No resolution yet.

Is there anyone out there that is currently able to use the Cesium Cartographic Polygon for clipping? I’d be very interested to see how you might be using it and that could help me identify why I’m running into such trouble.

I believe I have found the source of the problem. When adding the CesiumPolygonRasterOverlay, I had added it to “Cesium3DTileset”. I believe you need to add it to “Google Photorealistic 3D Tileset” instead, and make sure to select “CesiumCartographicPolygon” from the index. Check to “Invert Selection” and uncheck “Exclude Selected Tiles”.