Hide Parts of Tilesets with Cartographic Polygons - Not clipping

I followed the guide Clipping Tilesets – Cesium . I have got to the end but it is not clipping the area I selected. I am trying to outline the area I want from the Cesium World and just use that area. Is using Cartographic Polygon correct for this? If so how can I fix this so it will cut the area out for me to work with?

You need to put the CesiumPolygonRasterOverlay on the tileset you’re trying to clip, not the cartographic polygon.

Is that a different Actor? I used Cesium Cartographic Polygon since it is in the Basic Actors and after setting up my outline I added CesiumPolygonRasterOverlay in the CesiumCartographicPolygon Details.

Right, and I’m saying that won’t work.

You can keep the Cesium Cartographic Polygon as-is, but remove the CesiumPolygonRasterOverlay from it. You have to attach the CesiumPolygonRasterOverlay to the tilesets that you want to clip. Any Cesium3DTileset actors that you want to apply clipping to has to have the CesiumPolygonRasterOverlay attached.

It looks like you have multiple tilesets in your level, so I can’t tell which one you’re trying to clip out of. But select one (or all) of them, and in the Details panel, attach a CesiumPolygonRasterOverlay component.

In general, any component with RasterOverlay in the name is meant to be added to a Cesium3DTileset actor. Otherwise, it won’t really do anything for you.

I see that you have both Cesium World Terrain and Google Photorealistic 3D Tiles in your level, so you may want to remove one of those tilesets. Then add the CesiumPolygonRasterOverlay component on the remaining one, so that it can work with clipping.

1 Like

That worked thank you!

Removed: The Cesium OSM Buildings, Cesium World Terrain.
Removed the CesiumPolygonRasterOverlay from the CesiumCartographicPolygon
Added CesiumPolygonRasterOverlay to Google Photorealistic 3D Tiles!

1 Like

Good morning
I’ve tried to do the cropping myself with the directions explained above, but it doesn’t work.
I’m sending you a screenshot to make you understand better.

Thank you

Hi @LeonardoGiacobazzi,

In the CesiumPolygonRasterOverlay, look at the polygons array. Currently, it doesn’t point to any valid polygons, so the component can’t use them. Click the dropdown that says “None” and find your desired polygon, then refresh the overlay / tileset.