Cesium Asset loading issue: Failed to load resource: net :: ERR_CONNECTION_CLOSED

Cesium assets are not loading and observed below console error:

If I hover over this error and it shows the get request:
{“type”:“GLTF”,“url”:“https://assets.ion.cesium.com/us-east-1/<ASSET_ID>/model.glb”,“accessToken”:“TOKEN”,“attributions”:[{“html”:“Cesium ion”,“collapsible”:false},{“html”:“Upgrade for commercial use.”,“collapsible”:false}]}

But if I reload the page, it works.

Hi Suncor,

Are these errors for the preview in Cesium ion, or a Sandcastle, or another application? Can you provide the asset id of one of the assets you are having trouble loading? This information will help Cesium troubleshoot the problem. Thanks,

I am trying to load assets in React application and facing this issue for all the assets (in my Cesium ION account). This error log was for assetId: 1673644.

The Sandcastle is working fine. But our React application is huge and data loading is on large scale (thousands of positions per second).

Since it is working in Sandcastle, that indicates that it is something on your system, your network, or specific to your application.

Here are some things to consider:

  • Is your app simply loading so much data at once that requests are timing out and you need to throttle your own application? Does the problem go away if you load less data as a test? Here are some suggestions on how to reduce your data usage.
  • Have you tried running the application on a different (or even faster/slower) network to see if that lessens or worsens the problem?
  • Have you tried to reproduce the issue in other browsers or operating systems?

Since this error has more to do with your specific application than it does with ion servers; so it’s not possible for us to address the issue from our side unless you have details that point to the problem being somewhere on our end. If you’re able to supply more details, we might be able to help.