Cesium.ClippingPolygon is not a constructor

Hi. Thanks for the cesium and for the features you are adding regularly.
I am trying to test your new feature “clipping” - hiding terrain or buildings but experiencing an error. Please, don’t be angry if there is something minor. I mostly work with python.

I am using a local server with vite. It works fine. I am experiencing a problem when I want to test a new feature ClippingPolygon. The version of Cesium is 1.117, so logically, the new functions should be included.

1. A concise explanation of the problem you’re experiencing.
app.js:51 Uncaught TypeError: Cesium.ClippingPolygon is not a constructor at…

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

// Add OSM tiles.
const buildingTileset = await Cesium.createOsmBuildingsAsync();

function hideBuildings() {
  const clippingPolygons = new Cesium.ClippingPolygonCollection({
    polygons: [
      new Cesium.ClippingPolygon({
        positions: Cesium.Cartesian3.fromDegreesArray([
          -6.240115, 53.347674, -6.239911, 53.348736, -6.238978, 53.348676,
          -6.239158, 53.347578, -6.240115, 53.347674,

  buildingTileset.clippingPolygons = clippingPolygons;

4. The Cesium version you’re using, your operating system and browser.
Cesium: 1.117.0, Windows 10, Google Chrome.

Thank you.

Okay, I got it resolved. I was using vite. I suppose I did something wrong there. Then tried to use webpack and I followed this example

Now it works. Thanks everyone who visited this page.

updating the packages(js+css) help (cesiumJs v.1.119)