Cesium fails on wxWidgets


I am using the wxWidgets' wxWebView control to bring the Cesium view.
The backend is IE 11 (shows as InternetExplorer_Server).
It fails with errors below. Running the same works fine outside wxWidgets.
Did anyone try Cesium with wxWidgets?

Thank you,


RuntimeError: The browser supports WebGL, but initialization failed.
   at t (http://localhost:55005/Build/Cesium/Cesium.js:379:29075)
   at $ (http://localhost:55005/Build/Cesium/Cesium.js:404:826)
   at vt (http://localhost:55005/Build/Cesium/Cesium.js:412:21872)
   at A (http://localhost:55005/Build/Cesium/Cesium.js:417:15117)
   at A (http://localhost:55005/Build/Cesium/Cesium.js:419:19452)
   at Global code (http://localhost:55005/Apps/HelloWorld.html:42:5)

I’ve never used wxWidgets, but the answer is the same no matter the widget framework. Even if IE 11 is installed on the system, the WebBrowser control, which is what wxWebView uses as the back-end, defaults to IE 7. To ensure that you are using IE, you have two options.

  1. If you are in control of all HTML that will be displayed in the control, you can add to all of your HTML pages to ensure the latest available IE rendering engine is used.

  2. If you are not in control of all HTML that will be displayed, then you must add a registry key that makes your app use IE 11.

Also, performance will be slow if you don’t add a key to the registry (which can be done at runtime) in order to have your app use accellerated 3D: http://stackoverflow.com/questions/25051072/ie-11-webgl-performance-slow-when-using-webbrowser-control

Other helpful links:



Thank you Matthew, I tried that before with different combinations. Still no luck. Btw, the error message says The browser supports WebGL, could be an issue in Cesium?

I would be highly surprised if it were Cesium. This can be easily checked by just having your widget navigate to http://webglreport.com/ and you should get a similar failure message.

Does Cesium work in normal IE 11 operation on your machine? It’s also possible that it’s not your app but a system-wide issue.

Yes, outside in IE 11 it works perfectly.