Cesium JS 1.110 suddenly not working - internal dependency issues

I have been using Cesium 1.110.0 and suddenly started experiencing errors last week. The error is:
DeveloperError: Width must be less than or equal to the maximum texture size (0). Check maximumTextureSize.. I also ran into a similar issue with version 1.109.0 a while back. While the errors were different, the root issue seems to be the same.

After a lot of investigation, I found that internal dependencies for Cesium had suddenly changed. In looking at the package.json for the cesium library, I see the following dependencies.

 "dependencies": {
    "@cesium/engine": "^6.1.0",
    "@cesium/widgets": "^4.3.0"

I may be missing something here, so please let me know if I might be doing something wrong, however the dependencies that start with the ^ mean that the actual version used can change without the user knowing that it changed. For instance, if Cesium releases a higher version of these dependencies (increasing either the minor or patch version numbers), the newer versions would be picked up, even though the version of the primary lib (Cesium) hasn’t changed. I believe this is exactly what happened.

Originally, Cesium 1.110.0 was using the following:

  • @cesium/widgets v4.1.0
  • @cesium/engine v5.0.0

Last week, those versions changed to:

  • @cesium/widgets v4.3.0
  • @cesium/engine v6.1.0

This happened internally, without me changing any cesium version. Since it happened twice now, I wanted to alert the Cesium team and see if 1) I am doing something wrong, or 2) these dynamic version ‘^’ characters should be removed from Cesium’s internal dependencies.

My issues have been fixed and to prevent the issue from happening again, I have had to implement internal dependency version overrides for the Cesium package. I have since upgraded to Cesium version 1.111.0, but updated the overrides to prevent issues like this in the future.

Can you please advise and let me know your thoughts? I was going to create a repro sandcastle, however it won’t allow me to create one based on a previous version of Cesium. I would think that this has been reported already, but I haven’t been able to find it.


Cesium team, it has been more than 9 days since I posted this - is it possible to get a response? While I understand that since I have resolved my issue by forcing Cesium internal dependency versions, my team has been stung by this several times and I want to either know if there is something should do differently, or affect some change in the CesiumJS codebase to prevent it from happening again and/or to others. I am happy to help with clarification, reproduction or code examples if that helps.

(Tagging @Gabby_Getz just in case it helps)