CityGML textures missing

Hi there,
I have a CityGML ZIP-File containing the respective xml as well as texture files in subfolders. I tried uploading the files in different ways (zipped, unzipped, with and without sub-folders; IDs 2026820, 2026863 and 2026877). However, the textures never show up after uploading and processing, even though the respective source files are there.
Any clue what I am getting wrong?
Thanks a lot in advance!


I downloaded your asset with the id 2026877 which was a zip file of the asset. Looks like in the xml file, you the textures referenced with tags <app:imageURI> are using all lowercase for folders that you have your textures in. But the folders have an uppercase letter to start (e.g wall vs Wall). I replaced all the tags to use the first letter uppercase folder and it worked with the textures showing.

Please give this a try and reach out again if you continue to see any issues.


Thanks a lot Ankit, sometimes the solution is so simple that it tends to be overlooked.
I just changed the lower case to upper case characters and now everything seems to work as intended.
Best regards