Clipping Tilesets when the 3dtileset has moved position

Good Morning.
I’m having difficulties clipping the Cesium globe terrain, using Cartographic Polygons. its works fine when the globe is positioned at 0,0,0. However if i move the globe (which i need to do, to overlay with my design data) then the Cartographic Polygon doesn’t project properly and the cut out shape in the tileset is in the wrong position with the polygon. Is there any king of workaround.
I cant move my design data as its streamed into Unreal in a fixed position, thus i need to move the globe.
The attached image, shows the globe with an X,Y position offset, the polygon is at 0,0,0. You can see the hole in the terrain is offset away from the polygon.
ideally, i want to position my globe, away from 0,0,0 and to move the poloygon shape to a desired location, and for the cut out to be projected directly below the polygon
Grateful for any support.

This is a known problem that has been fixed in Cesium for Unreal v2.0, which will be available as a preview relase really soon now. In the current release, I think the only possible workaround is to move your design data instead of moving the globe.

Thank you for getting back to me @Kevin_Ring ill await V2.0

The v2.0 preview is now available:

1 Like

Hi @Kevin_Ring
i have installed V2.0 preview release. However I still seem to be getting the same results when off setting the globe.

are there any other steps i need to apply?

Thanks. I think you’re running into a bug that is fixed by this PR:

If you want to try out the build from that PR, the instructions for doing so are here:

Thanks @Kevin_Ring that works perfectly
Is support for UE5.0 completely dropped now?

Yes. Cesium for Unreal v1.31.1 was the last release for UE 5.0, per the release notes and changelog. Starting with Cesium for Unreal v2.0, the earliest version we will support is UE5.1

@janine & @Kevin_Ring thank you both, preview testing with 2.0 works perfectly with 5.2