CZML Polygons are not displaying on the globe

I've been upgrading our version of CESIUM from b28 to 1.2. As part of the upgrade I've had to refactor all instances of "vertexPositions" in our czml to use "positions" on the polygon object itself. After I made this change to use "positions", none of the polygons (for example, country borders) are displaying on the globe. I've tried versions 1.0, 1.1 and now 1.2. I've stopped at 1.2 because of a sensor plugin issue with 1.3 and 1.4.

To rule out syntax errors in the czml, I took the "simple.czml" example from sandcastle and dropped it in my application. All of the objects from the orbits, billboards, labels and points load properly EXCEPT the polygon outlining the border of Pennsylvania.

I've tried loading the czml with both .process and .load on the czmlDataSource object.

Any insight as to why this would be occurring would be greatly appreciated. I do not have any errors in the console.


I noticed today that in conjunction with the border of Pennsylvania not showing up, the satellites are not moving around their orbits like they do in sandcastle.