Ellipse outline clipped by terrain/mesh

Hello. I have a question regarding ellipse outline behavior.

I simply wanted to draw an ellipse with an outline. I set the height to 1 because I wanted them to be at least at the same level as the ground.

Here’s the sandcastle link to demonstrate them.

As the sandcastle shows, to show the outline I have to set the height. However, the outline looks clipped by the terrain in certain zoom level. Here’s one example:

Peek 2021-09-01 15-43

If I didn’t want them to clip, seems like the only option I could do is to not use an outline. In the sandcastle I also showed a polyline which doesn’t seem to behave that way.

Note that I tested this on our own 3D tileset and the clipping also happens, so I don’t think it’s a tileset issue.

My question is, is there any other way I could show the entire circle with the outline, without it being clipped? I tried the zIndex approach and it doesn’t work. Or is there a way to make the behavior similar to the polyline perhaps. Or, if the outline could “drape” all over the terrain instead.

Thank you.

1 Like


Thank you for sharing some preliminary details on your application. I was able to reproduce the issue on my machine - the circle clearly seems to be cut off by the 3D Tileset. My first suggestion would be the zIndex approach. However, it seems like you have already tried this. Can you share some more details about your implementation of this approach? It is possible that you missed something.

CesiumJS does support draping polygons over terrain. The classification sandcastle demo shows how this can be accomplished.

As seen here, we can drape a red highlight box over a 3D Tileset.

Let me know if you have any more questions or concerns. I am looking forward to learning more about your application!