EPSG:4326 services issue

Hello, I am working with some Tiled ArcGIS image services and map services with EPSG:4326 and I can't manage to draw them with Cesium. All the tiles that are requested don't exist in the service's cache, for example tile/0/0/1 not found. In the Cesium.Viewer I set the baseLayerPicker as false and the mapProjection as new Cesium.GeographicProjection. Moreover, when I use Tiled ArcGIS services with EPSG:3857 I manage to draw them successfully.
I will appreciate any help, thanks in advance


Hard to say what’s going on without more information. Can you share the code you’re using to configure the imagery layer and the output of the server’s /MapServer page?



Thanks for your quick reply Kevin here is my service's WebAPI, go to this link:

One more thing I have forgotten to mention before is that I am using a custom Tiling Scheme in my image service and not the default WGS94.

That looks like a pretty normal MapServer. Why do you need to specify a custom tiling scheme? I think the default one should work fine. What error or problem are you seeing exactly?

My issue is that the tiles that are been requested from the service in the format: tile/0/1/1 doesn't exist, I tried to use both ArcGisMapServerImageryProvider and WebMapTileServiceImageryProvider.
The cesium map is just colored with blue.

Hmm, looking at your MapServer, I don’t know why numbered tiles (for example /0/0/0.png) wouldn’t exist. The document claims they should… When you click on the “Start Tile” and “End Tile” links in the ArcGIS Server UI, especially at level 0, do they work? If so, how are those URLs different from the ones Cesium creates? Are you seeing any other errors in the console, perhaps about Cross-Origin Resource Sharing? It’s normal for some of the tiles to not exist, but if they’re all missing it’s a little mysterious.

Our start tile in the highest scale is 0/2/1 in the end tile is 0/3/3 is it a problem that it doesn't start with 0/0/0? It works just fine with ArcGIS js API.
Also, about the CORS we don't have a Cross Origin issue.

Ok, the problem is certainly the custom tiling scheme that you’re using. The standard one would only have two tiles at level 0.

It may be possible to make Cesium work with tiles in your custom tiling scheme, but I’m not sure. The only thing I see that “might” help Cesium do this is the Origin property, but it’s not clear to me (even after trying to find some docs from Esri on the subject) what that property actually means.

If you can tell me more about how you’ve configured your tiling scheme, I may be able to help. Out of curiosity, can you tell me why you weren’t able to use the standard scheme? I imagine this creates problems using this layer with other non-Esri maps as well.


Hello Kevin,
I tried using the default tiling scheme that have only one tile in his zero level and still the tiles that are been requested from using the WMTS provider are not found. For some reason the cache that was created using ArcGIS Server for my WGS84 image service never start with tile index 0/0 in any level maybe this is related to my issue?