Error occurred compiling for Windows

HI when i tried compiling my project i get the following, any advice please? Means nothing to me

Those “database is locked” errors are non-critical. They’re usually caused by the Editor and a built game (or perhaps a being-built game) trying to access the cache database simultaneously. When you see them, it means the cache isn’t working, but this will not break anything (just make tileset loading slower).

Other than that, your log seems to indicate success so far. Is it failing later?


Thank you for getting back to me so quickly.

We are building an Archviz app, based up the collaborative viewer template in UE5

As you can see from the attached, it starts throwing other errors towards the end. The end result is we get no files output.

Can you tell if this is to do with your plugin or something else unrelated?

(Attachment Unreal2306.log is missing)

Hi @TheExcelExperts,
It looks like the log file didn’t come through. Can you try again?

Hi Kevin
Just updated to ue5. 1 so are there any novice instructions on how to compile cesium for unreal plugin?
Then I’ll try building the project again…

Instructions are here:

But I can’t promise they’ll work in the UE5.1 preview because no one has tried it yet (to my knowledge).

In general, if you’re not able to package a game using the Marketplace-installed plugin, then starting with a custom built version of the plugin instead will only add complexity and reduce the chances that everything goes smoothly.

That is a very good point that you :blush:

I will wait until the official plugin in released. Is there a notification I can be sent when it is launched on Marketplace?

We announce new releases on our blog:

They’ll also show up on the GitHub releases page: