Error Upgrading to Cesium 1.11.0 with Unreal Engine 4.26

Hello –

I have a world that I’ve been using with Unreal Engine 4.26.2 and Cesium 1.6.2. I wanted to upgrade to Cesium 1.11.0 to take advantage of some of the new features. The cesium plugin was originally installed via the marketplace on the epic games launcher and I updated to v1.11.0 through the same method. However, I am now unable to successfully open my world through the Unreal Engine. I am receiving a message that says “Plugin ‘CesiumForUnreal’ failed to load because module ‘CesiumRuntime’ could not be loaded. There may be an operating system error or the module may not be properly set up.”

This error occurs regardless of if I am using a brand-new world or the world I was previously working in and also occurs when attempting to upgrade to Cesium 1.11.0 on a different computer. I was able to get a brand-new world to work in Unreal Engine 4.27 with the latest Cesium plug-in so this seems to be an issue exclusive to 4.26. Ultimately, I would prefer to fix 4.26 and not use have to use 4.27. As additional information I am running OSX version 10.15.7.

Do you know how to solve this?


Hi @aagudelo,

By any chance are you using an engine built from source, rather than the official Epic-supplied 4.26.2 build?


Hey Kevin,

I used the Epic-supplied 4.26.2 build for the Unreal Engine (meaning I downloaded it by clicking the button in the epic games launcher to install 4.26.2).

Thanks for looking into this!

Another update:

Before I was using the epic launcher to install cesium, but to test an older version. I instead downloaded the releases from the github pages

And put it in the plugin folder.

When I installed the old version v1.6.3 the world loaded normally. I then tried other versions and anything later than v1.6.3 failed to load with the same issue. I.e v1.7.0, v1.11.0 etc

When I tried installing an older version like v1.6.0 it did work.

I wonder if something broke in v1.7.0 and later or if something needs to be recompiled? But I cannot recompile without loading the edit as far as a I know