Flatten terrain under the model

Hi, I have a small bit of the terrain recreated in the reality capture and exported to cesium.
That renders nicely. But my terrain is more accurate/up to date. then Cesium World terrain.

The problem I see is that I cant clamp it to the ground as the Cesium terain will stick out in places.
Like in a places where forest was cut and up to date terrain is much lower now.

An option to flatten/disable cesium world terain just under the asset that is ground and treat it as a ground would be a welcome addition.

This would enable the proper above the ground measurments as now it treats my ground model as feature.


Can you provide the asset ids and asset types that are shown, or a link to to the story? That will let us confirm what is happening. It isn’t possible to have two terrain type assets loaded at the same time so it is likely that one or more of what you referred to as terrain is actually a 3d tiles asset.

From the screenshot it looks like there is at least one 3d tiles asset that is not aligned with the current terrain asset (or another 3d tiles asset).

Currently Cesium Stories does not have an option to cut out a section of the terrain or 3d tileset. This is a feature that we are considering implementing, but there is no timeline for it yet. If you are using CesiumJS, there is an option to use clipping polygons to hide parts terrain or tilesets.



This is the story, I understand there is only one terrain, but it happens that my model i mainly terrain. and in places when it exists , i’m confident it is more up to date so i want it to show and be main terrain

It looks i need become friends with cesiumJS