Globe missing using cesium sensor volumes plugin offline

1. A concise explanation of the problem you’re experiencing.

I’m using the cesium sensors plugin with a .czml file generated in STK. The sensor volume appears for the Geoeye1_33331 satellite, but there is no global earth image.

I see the outline of the earth with atmosphere representation but there are on continents, oceans etc., just a black sphere.

I need to have the sensor volume capability running offline without any internet support.

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

I get the blank sphere when I define the cesiumContainer like this:

var viewer = new Cesium.Viewer(‘cesiumContainer’);

However when I try add the globe from a local source like this:

var viewer = new Cesium.Viewer(‘cesiumContainer’, {

imageryProvider : Cesium.createTileMapServiceImageryProvider({

url : Cesium.buildModuleUrl(‘http://localhost:8080/Assets/Textures/NaturalEarthII’)

////url : Cesium.buildModuleUrl(‘Assets/Textures/NaturalEarthII’)


shouldAnimate : true,

baseLayerPicker : false,

geocoder : false


I get nothing at all, just a blank browser window. I’ve tried placing the Assets folder in different places

in the cesium-sensors folder but none of them have worked so far.

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I need to have the sensor volume capability running offline without any internet support.

I will have .czml files describing a scenario including satellites, and missiles.

I need to add sensor volumes to some of the satellites in the scenario.

The sensors will have different fields of view and viewing angles.

4. The Cesium version you’re using, your operating system and browser.

v1.59 with Edge browser

Where did you download the sensors plugin from?

It’s been a while but I believe I got it from :

Thanks for letting me know. That plugin is no longer maintained. It’s been superseded by the analytics SDK which requires a commercial license: