GLTF models are rotated since 1.47 - how to fix CZML?

(follow-up to )


I have tried to update my CZML files as suggested using:

   "position" : {
        "cartographicDegrees" : [longitude, latitude, height]
    "orientation" : {
        "unitQuaternion": [ x, y, z, w ] // compute values using method in #6738
    "model": {
        "gltf" : "..."

But previously I had "velocityReference": "#position" inside "orientation", in order to have the aircraft oriented with regard to their route.

Here is what I tried:

                "orientation" : {
                    "velocityReference": "#position",
                    "unitQuaternion": [ 0.0,-0.7071, 0.0, 0.7071 ]

(found the values on )

But it does not work.
Is there a way to fix my CZML files?


Orientation can only have one value, so if you’re already using a velocity orientation, you’ll have to re-orient your model a different way. I would recommend opening the source model in a model editing program and applying a 90 degree rotation then re-exporting it. If you are unable to do this, let me know.



The models are not mine, they come from I will open a ticket there and see what I can do.

Thank you
Best regards