Grey image tiles while moving away from the ground in UE 5.2.1


I ran into a problem in the new version of Unreal Engine 5.2.1 and latest Cesium from Marketplace.
Image tiles disappear as the camera moves away from the ground. I attach YouTube video.
That happens only in Shipping build. If I ran it in the editor - it works fine.

There is nothing special in my app. It’s just Cesium globe with “Bing Maps Aerial” and “Cesium World Terrain”. No special options were added for the project.

Previously I worked a lot with UE 5.0 and 5.1 and there were no problems. Any ideas what I am missing?

Kind regards,

That’s very strange. I don’t think I’ve ever seen something like that before. Can you reproduce it with the Cesium for Unreal Samples project as well, or only in your own project?

Just tried to pack a Shipping build of freshly downloaded Cesium for Unreal Samples (from Marketplace) and I got the same problem! I even did it on different machine with freshly downloaded UE 5.2.1.

I attach a link to Google Drive with this Shipping Build for Windows. So you could check it by yourself.

If there are any suggestions that I can try to fix it, then write to me, I will try.

Ok, I can reproduce this. I’m still investigating, but the problem has something to do with the water rendering. So, as a workaround, uncheck the “Enable Water Mask” property on the Cesium World Terrain tileset, under Cesium → Rendering.

1 Like

I wrote an issue for it: