Grey Screen on Andorid

So I’m using the latest’s version of Cesium and everything works great in the editor and on desktop. But when I build to android and test it, all I get is the blank grey loading screen. I’ve done a lot of research and I think there may be a permission I need for it to work? Could anyone point me in the right direction? I’ve tried multiple emulators and real devices, and all of them have the same problem. No error is thrown in any log too. Any help is much appreciated thank you!

Does the Cesium for Unity Samples project work for you on Android? Releases · CesiumGS/cesium-unity-samples · GitHub

I downloaded it, switched it to android and it says it won’t install on my device. I tried the usual cache clearing method and that didn’t work. Thank you so much for your quick response!

Can you tell me the exact error? “it won’t install on my device” is a strange one. What sort of device is it, anyway?

Yes sorry! I use bluestacks which works well with everything I’ve done with unity. Here is my image of the error when I try to add the game to it.

Which I have run into before but the solution is to clear the cache in unity and delete the app on the emulator but that didn’t work.

Hmm I really have no idea. Can you get more information from bluestacks somehow? That’s a very generic error message.

Does bluestacks emulate ARM64, or is it Android on Intel? Either should work with Cesium for Unity. Definitely make sure you’re targeting a 64-bit processor, though. Neither 32-bit Intel nor ARM are supported.

Ok, thank you, but any ideas to fix the grey screen? Like I said I have it working completly on desktop and in the editor. Here are a few warnings I get and then my android settings

You problem is that you’re targetting ARMv7, which is a 32-bit architecture and therefore not supported. You need to switch to ARM64, as I mentioned above. It’s grayed out because Unity doesn’t support Mono on ARM64. You’ll need to switch to il2cpp instead.