How does Cesium real-time handle timezones whilst uploading czml?

When I use czml data source like so:


The realtime button on the animation widget applies an offset. So essentially the realtime information ends up being one hour off the mark. Is it possible to nullify this offset?

I’ve attached 2 photos showing realtime before and after the the czml data was loaded.



CZML contains clock settings which are applied after loading the data source. Also, neither of your pictures show Cesium in realtime mode (activated in the GUI by clicking the clock icon on the top-left of the animation widget)

If you want simulation time to always match system time, then you can specify “step”: “SYSTEM_CLOCK” in your CZML to set the client to realtime mode.

Alternatively, if you construct the Viewer with

automaticallyTrackDataSourceClocks : false

then the client will ignore clock settings specified in CZML.

Thank you for that information. The clock is now fixed however objects on the globe are still trailing one hour behind where they are supposed to. (this is rectified when I change my local time to UTC). Is there a separate setting for this issue?

Check your CZML to make sure that all dates are in UTC. All dates, including the start and end of ISO8601 intervals, should end with Z to indicate UTC. This is a common error when generating CZML by hand. Omitting time zone indicates that the ISO8601 date is in client local time, which is usually incorrect.