How to disable default lighting on model ?


I have a Collada model, with no lighting in it. But it looks bad in Cesium due to lighting.

Below is an illustration of the problem. Open the same model in Xcode, and there is an option for lighting: “Disable Automatic Default Lighting” and “Enable Automatic Default Lighting”. Upper one is what i want, and the bottom one is what shown in my Cesium.

So is there a way to disable auto lighting for model ?

Thanks for help.

Thanks for help.

We don’t have a way to do this yet. I plan to provide the ability to replace the glTF shaders on load soon, which you could use for this. In the meantime, there is similar functionality in #2290, but I have not looked at it.


Thank you Patrick for the updates.