How to insert 3D models on Globe

Hi all.

I have 3D models in .kmz format. And when I open file in Google Earth, I get this (picture: ).

It's just one small street corner.

I read that I need to convert COLLADA (.dae) to glTF. And I found out that I must change extension of my .kmz file to .zip, extract files and I get this: and this:

After that I went to Cesium online converter .dae ---> glTF and glb.

And whole folder with all files put on my localhost.

Where is the problem.

Problem is first, that even even I go to Sandcastle examples, to load .KMZ files (from localhost), I don't get anything at first ( I don't have any errors in console ), but, I get this after few seconds:

Than, I tried 3D-Models-Tutorial code, I put a link to my .glTF document on my localhost (, I and get nothing again, thi (I left the same position).

Please help me.

Thank you.


Have you tried loading your models into Cesium not using the KMZ file? Maybe there was an error in the conversion.

Here’s an example for how to show models in Cesium:

Did you change your KMZ to point to the new glTF files?