KMZ Files in Cesium

Is there some reason why some kmz files made for Google Earth dont work in Cesium. I downloaded kmz file from: <>. The file doesnt work on Cesium. I tried to convert it to collada with SketchUp and to gltf with cesium converter. Gltf converter doesnt work with the file.

KMZ support in Cesium is still incomplete, while many features work, there are others that still need to be implemented. We currently print out a message in the browser console when we an encounter unimplemented ones. In this case, we don’t support KML models yet. The official roadmap is updated as we add additional capabilities: and we also mention new features in with each release.

If you ever feel that a feature we claim to support isn’t working as intended, let us know. It would also be helpful if you can share your KML file with us so we can easily reproduce/debug the issue.

Thanks for reply.

I attached some sample files. First two files: file1.kml and file2.kmz worked fine in Cesium with viewer.dataSources.add(Cesium.KmlDataSource.load()) command. file3.kmz doesnt work and i dont get any error message.
file3.kmz works fine when i converted it to gltf. file3.kmz is exported from SketchUp.

Is it possible to get the position of glft model on map from the file like in kml files?

file1.kml (570 KB)

file2.kmz (10.7 KB)

file3.kmz (831 KB)

You are correct in that it looks like we are not spitting our a message about Models not being supported. I’ll make a note to fix that with the next release.

For your other question, one data is loaded, you can iterate over the kmlDataSource.entities collection and get the position property of each entity. It’s the same for all data sources, whether GeoJSON, CZML, or KML. Check out the Visualizing Spatial Data tutorial for more information on Entities.