Internet Explorer 11 fails to load Cesium terrain data


Is there a known issue with the CesiumTerrainProvider and IE 11? I just started testing an application with IE 11 and I’m getting the following error when trying to load the terrain data.

An error occurred in “undefined”: Failed to obtain terrain tile X: 1 Y: 0 Level: 0.

An error occurred in “undefined”: Failed to obtain terrain tile X: 1 Y: 0 Level: 0.

If I switch to VT MAK terrain data, no errors.

I am able to load terrain data with CesiumTerrainProvider in Firefox and Opera.

I tried to load the Sandcastle ( to see if the Terrain example worked in IE 11 but the page fails to load.

Internet Explorer 11 (version 11.0.9600.17959CO)



Hmm, I’m not sure what the problem would be. The terrain loads fine for me in IE 11.

Eric, can you get to in a browser?

Sorry, hit send to soon.

  1. Does it work in other browsers for you?

  2. Can you browse to in IE (or others)?


I am able to load my application in Firefox and Opera without issue.

I can browse to the provided link in IE, Firefox, and Opera.


Hi Matt,

I would like to ask help on loading terrain hosted from Google Earth Enterprise. I load DEM into GEE and consumed it using GoogleEarthEnterpriseTerrainProvider in my 3D web app using cesiumjs. It is showing as expected in Edge and Chrome but in IE11 it doesn't show at all. Can you advice me of how to fix it?

Thanks in advance.