Issue while using unity to build apk map disppeared

Hi, I am using Google map api key to create cesium3dtiles in unity. And it work. But when i build android apk, there’s no any 3dtileset showed in app. I read some similar question. I already set android player setting to ARM64, it didn’t work either. Is the api of google can’t use in apk? or i did something wrong in playersetting? thanks!

Hi @chahui,

We’re not aware of anything that could prevent Google’s Photorealistic 3D Tiles from appearing in Android. Can you help us troubleshoot by providing the following information:

  • What version of Unity are you using?
  • What version of Cesium for Unity are you using?
  • If you use a different tileset, such as Cesium World Terrain, does it appear on Android?
  • If you have Android Debug Bridge, it would help if you could debug the application and see if there are any logged errors.

Thank you!

Thanks you for replying.
-The version of unity is 2022.3.16f1.
-The version of cesium for unity is v1.7.1.
-For using different tileset, since i need to have 3d scan building information and i’m using map in Taiwan. There’s no 3d tileset in this area. I checked cesium asset depot looks like only google map have 3d tile in Taiwan. So the other tileset will not suit for me. I tried cesium world terrain It did show on the app.
-I’m not familar with android studio i tried to open sdk file i build from unity. It said “Could not identify launch activity: Default Activity not found Error while Launching activity”

It just work somehow. i use patch and run while connect to my phone.
i check unity build setting >>Development build, script debugging, wait for managed debugger. And it work somehow. Anyway, thanks you for helping me for solving issue!

1 Like