Issues with implementing cesium

i've been using this article:

to integrate between cesium and react.

I've passed the whole article and it worked pretty good.

I've tried two things:
1.creating another billboard when using a JSON file to read the data, I can see the data is OK in the log but for some reason the billboard isn't displayed.
2.creating an entity and adding it to the entity collection,getting the error below while rendering:

An error occurred while rendering. Rendering has stopped.
TypeError: primitives[i].update is not a function
TypeError: primitives[i].update is not a function
    at PrimitiveCollection.update (http://localhost:3000/static/js/bundle.js:178201:27)
    at updateAndRenderPrimitives (http://localhost:3000/static/js/bundle.js:183491:27)
    at executeCommandsInViewport (http://localhost:3000/static/js/bundle.js:183351:13)
    at updateAndExecuteCommands (http://localhost:3000/static/js/bundle.js:183214:13)
    at render (http://localhost:3000/static/js/bundle.js:183782:9)
    at tryAndCatchError (http://localhost:3000/static/js/bundle.js:183802:13)
    at Scene.render (http://localhost:3000/static/js/bundle.js:183844:13)
    at CesiumWidget.render (http://localhost:3000/static/js/bundle.js:229840:25)
    at render (http://localhost:3000/static/js/bundle.js:229215:32)

Another thing i would like to ask is,
would you recommend using the react&cesium integration manipulation? is there any other solution for easy usage of the framework?

the app i'm developing is for work, trying to integrate between a system that holds entities all around the world to cesium.js

I'm using the latest cesium version, chrome and win10.

Thanks a lot,

I can’t tell off the top of my head why you’d get these errors. Can you post the code you used to add the billboard and the entity?

As long as the environment you have can render a web view/html page, Cesium should work just fine. I don’t believe there should be anything special with regards to React, but here is an official Cesium tutorial on integrating with webpack that might help:

So currently I’m stuck on displaying an entity.

I’m using React JS components logic, it did work with the sample from the article above but not working with entities inserted from JSON , I’m having trouble inserting into the entity collection.

attaching my code below,

the problem I’m having right now is showing an entity.

I’m seeing that it was added to the collection on the code below , but when I’m logging the viewer after the function runs, i see that it wasn’t added to the collection.

attached my code below.

inside src/cesium we have cesiumGlobe whos initializing the viewer

src/cesium/CesiumProjectContents who calls each component.

src/cesium/primitives holds inside the components I’m using

I need to focus on CesiumEntity

It’s a bit hard to dig through that project to find out what went wrong. Since you know the article’s sample project works I would start with that, make sure it works, and make one small change and see if that works. And make sure to consult Sandcastle ( and the docs ( to make sure you’re calling the CesiumJS API correctly.

You might also try contacting the author or opening a GitHub issue ( if you think it might be something wrong with their explanation/sample code.