Models and Polylinevolume Clipping at Ground Level

I have a question in regard to how models and polyline volumes are displayed. I noticed that when I place a model or a polyline volume either into the ground, or partially into the ground, the model is not clipped at the ground level. See the two attached images for a visual description. Both images are screenshots of the same scene, from different angles.

You can see that in the second screen you would expect to see the two shapes clipped at ground level, but they are fully displayed. Did I miss a configuration parameter where I can enable clipping, or is this a missing feature?

I’d love to contribute to this feature. Could somebody provide me some guidance on how to approach the problem, or give me any information that could be useful in tackling this issue?


I’ll answer myself. You can turn on depth test by using:

globe.depthTestAgainstTerrain = true;

The more I use this library, the more I’m impressed.