Suddenly without changes anywhere in my system I am getting this error which has been elusive and confounding.

Basically it results in the Cesium object not loading client side and results in

var viewer = new Cesium.CesiumViewer('cesiumContainer');

being undefined. And this applies even to the HelloWorld.html that comes with the server. From what ive gathered so far it has something to do with the Node.JS server script.

I made a modification to it to allow same network machines to be able to access it months ago only now for some unknown reason something about it is causing only the cesium resource to not be sent, i think anyways.

I tried standing up a new fresh cesium server instance and applied the same server tweeks and the problem replicates.

How can i modify the server code so that it publishes on the network

Update: thought this might help better describe whats not happening

You don’t need to modify the server code, just pass --public on the command line. That being said, the server shipped with Cesium is for ease of development only; Cesium itself has no server requirements. If you are deploying a real app (internally or publicly) you should really look into using your own web server, whether it’s IIS, Apache, or your own Node based one (starting from scratch, do not use the Cesium server as a template).

As for your code, It should be Cesium.Viewer not Cesium.CesiumViewer.

This definitely sounds like something specific to whatever server changes you made on your end. You’d probably need to share the code or relevant changes to diagnose it.

That’s the thing there were no significant changes and this might be more interesting for you:

So i did what you said reverted my other cesium instance to a pure vanilla build. then just used --public to make it accessible which worked (thanks).

only the problem still occurs. So essentially this problem is happening to a pure out of the box vanilla build of a cesium server.

-My browsers are communicating with the server all other modules loaded

-tried on both FF and chrome and cleared both their caches

and here is what is even more perplexing. Months ago I stood up a 1.6 version on a Tomcat and just to see if it worked i relaunched it, and It works just fine

What version of NodeJS are you using? A google search shows some issues with ERR_CONTENT_LENGTH_MISMATCH in some modules on older versions. For example:

Updating to the latest Node (0.12.2) may fix it for you: