npm run build only creates minifyShaders.state

Dear Everyone!

I would like to build Cesium from source, but something is wrong. I tried to follow the guide at's-Guide

After forking and cloning the repo I tried to run “npm install” and then “npm run build” from the project root folder. I received no error messages, but only a single file is present in the newly created Build folder: “minifyShaders.state”, and its content is simply “false”. I don’t think that is what I should expect.

I’m quite new to Cesium as well as to node.js, so it is highly possible that I did something wrong. Does anyone experienced the same issue? What is the solution?

Thanks in advance,

Gergely Padányi-Gulyás

Hi Gergely, you did nothing wrong and everything is working as expected. npm run build doesn’t need to do much because we develop Cesium with AMD modules. If you run npm start and browse to http://localhost:8080 everything will work and you cam use Sandcastle, Cesium Viewer, and the Tests. If you want to generate a full build of Cesium.js like you get in a release, you can run npm run release instead.

See the Contributor’s Guide for all of the details:

Hello Matthew,

Thank you for the answer. That indeed solved my problem.



  1. november 16., hétfő 16:50:43 UTC+1 időpontban Matthew Amato a következőt írta: