Offline model converter issue

Hi,
I am trying to use offline model converter COLLADA2GLTF

I convert my 3ds files to fbx using 3ds, them import to blender and export to dae. Online converter works fine, but when I use offline converter, it outputs following files:

*.bin

*.json

*0FS.glsl

*0VS.glsl

Why does not it outputs only gltf file. If I use*.json file in my projects, it gives error.

Also let me know wen online converter will be available?

Thanks,

Umar

Hi Umar,

Are you sure you are using the latest version of COLLADA2GLTF?

Also see glTF Tips for Artists: https://cesiumjs.org/2014/12/15/glTF-Tips-for-Artists/

And the Troubleshooting section of the Cesium 3D models tutorial: https://cesiumjs.org/2014/03/03/Cesium-3D-Models-Tutorial/

Patrick

The offline converter does not create a single file by default. Pass it the -e option to do so. There is also probably a bug in the converter where it should use .gltf instead of .json even when not embedding resources with -e.

I have just downloaded from https://github.com/KhronosGroup/glTF/wiki/Converter-builds

V0.8: *SHA1: df4892809111a8c6dbff4fab6c386a24745d344e *

for Windows.

*When I run, it says *msvcp120.dll is missing. I downloaded it.

Now when I run .exe, application does run.

I cannot see -e in /help

Thanks

I have no idea if those builds are up to date, but the option is definitely there in master, you may have to build it yourself from source. I would submit an issue to their repository: https://github.com/KhronosGroup/glTF since it’s technically a different project then Cesium they can better answer your questions.

I am stuck. I have downloaded https://github.com/KhronosGroup/glTF/ and cmake.exe. I have visual studio 10, but compiler does give errors. Can you please send me new .exe for offline converter.

Thanks

Hello

I’ve just updated my quite old build and had some issues since I always got the message: Build failed. So I investigated the code downloaded today and compared it with my older code (downloaded on April, 6).

I’m sorry if the wording is completely wrong and my approach is awful, but at least I found a solution for me that works and I thought it could also interest someone else (and I’m interested if someone else has a similar issue):

Setting:

  • Mac OS X Yosemite (10.10.3)
  • XCode 6.3.2 (6D2105)
  • cmake: 3.2.2; pkgconfig: 0.28; pcre: 8.37; libpng: 1.6.17

I just followed the instructions here: https://github.com/KhronosGroup/glTF/wiki/converter

The problem was in COLLADA2GLTF > Sources > collada2gltfConvert > Source Files > GLTFAsset.cpp on line 217; 358; 398 and 420 with an error: “Use of undeclared identifier ‘getPathDir’”

I then replace the code lines as follows:

inputURI.setPathDir(getPathDir(aURI) + getPathDir(inputURI));

``

with
inputURI.setPathDir(aURI.getPathDir() + inputURI.getPathDir());

``

and
std::string folder = getPathDir(outputURI);

``

with
std::string folder = outputURI.getPathDir();

``

When I built it again it compiled without an error and the converter converts my files perfectly.

Regards
Martin

Hi Martin,

Sorry, we recently broke the build on Linux. It is now fixed in https://github.com/KhronosGroup/glTF/pull/386

Patrick

Did the new pull fix your issues on Linux?