pickPositionSupported false?

When i use pickPosition(windowPosition, result) → Cartesian3 function,the chrome return "DeveloperError : Picking from the depth buffer is not supported. Check pickPositionSupported."

Then i find the browse not support WEBGL_depth_texture Extensions.
My graphics card is a AMD graphics card, the driver has been updated to the latest.

It’s possible that your computer doesn’t support the WebGL extension needed to make pickPosition work. Take a look at WebGL report and see if 'WEBGL_depth_texture" is listed in the ‘Supported Extensions’ section: http://webglreport.com/
If the extension isn’t in that list, your computer doesn’t have the graphics support needed to make that feature work.

We did make a few improvements to pickPosition recently. If you’re not using the latest version of Cesium, it might be a good idea to upgrade to 1.31 to see if that fixes the problem.




have you fixed this with newer Cesium versions? I’m using Cesium 1.36 and the same problem as you had is still there.

BTW I’m also having a AMD graphics card.

Hi Hannah,

I have checked the http://webglreport.com/. In chrome, the list doesn’t have 'WEBGL_depth_texture". But in Firefox, it is in the list.

But the weird thing is: both browsers failed to work with pickPosition.

BTW: I’m using AMD graphics card as well.

Hi Shirui,

What version of Chrome? It’s available is in the list for me in Chrome v61.

The changes for each version are in CHANGES.md, there were a few changes tangentially related to picking if you take a look since 1.36.



Hi Gabby,

thank you so much for the reply. Yes, I’m using the latest version of chrome - Version 61.0.3163.100 (Offizieller Build) (64-Bit).

Besides, the graphics card driver, google chrome and **Firefox **have been updated to the latest release.

I searched the solution for a long time. Actually, I just found out something really interesting.

I use a Windows 7 OS with AMD graphic card FirePro 5000. ,

In google chrome:

WEBG_depth_texture is not in the webgl report list

pickPositionSupported is still FALSE.

In Firefox:

WEBG_depth_texture is in the webgl report list

pickPositionSupported is still TRUE.
But pickPosition always returns the false value (not where I clicked/hovered)

Today I have installed Ubuntu 16.04 through VirtualBox on my Windows 7. Everything worked fine with both the Google Chrome and Firefox in Ubuntu!

Before I install Ubuntu on my computer I was pretty sure my problem was hardware-related.

But now I really don’t know if this OS-related?? Maybe the compatibility of WebGL support in windows 7 with AMD FirePro 5000 is not as good as Ubuntu?

Have you or any member of your team had such problem before?



Hi Shirui,

This seems like a WebGL issue and not a Cesium issue. Since the hardware did not change but your OS did, I would think it has something to do with the drivers for the graphics card. From your reply, it looks like you have downloaded and installed the latest drivers for your specific card, but try seeing if anyone has had similar issues with WebGL in a similar situation.



Hi Gabby,

thanks for your reply.

One thing keeps bothering me is:

In Firefox, the WebGL_depth_texture is in the report list which means it is supported.

But the pcikPosiition still doesn’t work well such as this sandcastle picking example:

The Alt value is wrong and the label is only shown when I try to zoom in or out.